2008-03-05

WifiSwitcher更新

WifiSwitcherを更新しました。
 
先日のアイコン表示方法の変更に加えて、プログラム起動時の無線LANの状態確認と「有効なAPのみ表示する」オプションを追加しています。
 
 
あと、レジストリに設定を保存するときに不要なキーを作っていた問題を(こっそり)修正しました。
動作には影響ありませんが HKCU\Software\tauchi.net\WifiSwitcher以下の余分なキーは必要ありません。
コードのコピペばかりしていると変な失敗をしてしまいますね。
 

6 件のコメント:

おもち さんのコメント...

今更ですが更新お疲れ様です。
アドエスでminiStumbler、WifiFoFumがいまいち使えないから諦めていたところ、先日WifiSwitcherの存在を知り使わせていただいております。

使わせていただいているのに要望と言うのも厚かましいものですが、いくつか気になる点などもありましたので合わせて報告させていただきます。

気になる点と言うのは更新時に表示位置がリセットされる問題です。
画面が狭いために(笑)スクロールしてみている状態でも更新時間になると自動的に0,0位置に戻されてしまいます。
要望に関してはソート機能の追加、、あとおまけとしてリストの保存(設定によっては前回終了時のリストを自動的に読み込むなど)などが出来ると面白くなるのではないか?と考えました。

他の箇所の更新時などにでももしお時間がありましたらこちらの機能の実装も考えていただければと思います。
それでは日々お忙しいでしょうが、お体に気をつけて頑張ってくださいませ。
失礼いたします。

kazuaki さんのコメント...

おもちさん こんにちは。
コメントありがとうございます。

選択行の問題ととソート...耳が痛いですね。どちらも手抜きの結果です(笑

リストの保存の問題も含めて MFCを使うことで お手軽に解決できると思っていたのですが、年明けに勉強しかけたまま手つかずのままになっていました。
楽をしようとせずにゴリゴリと書いていった方が結果的には早いのかもしれませんね。

SY さんのコメント...

 始めまして、SYと申します。WifiAutoDisconnectからKillBatteryIconやWhereNowなど、実はかなり使わせてもらっているユーザの一人でして、いつも本当に重宝しております。まずはこの場を借りて、感謝の言葉を送らせて頂きます。有用なアプリを本当にありがとうございます。

 さて、WifiSwitcherなんですが、実はかなり最初の頃から使おうとして、今現在でも使えてない状況にあります。
「NdisUIOエラー」というダイアログメッセージが表示され、存在しているはずのSSIDも表示されないという状況になってしまいます。

 機種はアドエスでファームは最新。切り分けるにしてもどこから手をつけていいものやら、という状況ですので、このエラーがどんな時に表示されるものなのかなどをご教示頂ければと思います。

 Googleでエラー名を検索しても、ちょっと分からなかったもので・・・。

 お忙しいとは思いますが、ご対応頂ければ大変助かります。

 以上、よろしくお願いいたします。

kazuaki さんのコメント...

SYさん こんばんは。
お返事が遅くなり申し訳ございません。

「NdisUIOエラー」は WifiSwitcherで表示しているメッセージで、起動直後もしくはAPの検索を行うタイミングで NDIS(UIO1:)が開けないか 無線LANのデバイス名が取得できない場合にエラーが表示されます。

そういえば以前 X01HTを使っている方から「起動時にNdisUIOエラーが出て動かない」というお話を頂きました。
そのときは機種が違うからだと思っていたのですが、SYさんのアドエスでも動かないとなると何かタイミング的なものがあるのかもしれませんね。

とりあえず起動時に無線LANを有効にしないようにしたものを作ってみたのですが これだとどうなりますでしょうか?

SY さんのコメント...

 お世話になります、SYです。わざわざお手数をおかけ頂いて大変恐縮です。

 日中、いくつかの場所や条件でアップしていただいたバイナリで試してみたのですが、やはり同様の状態になりました。
 また、ウィルコム公式サイトにあった無線LAN自動サーチアプリを削除してみたのですが、これもやはり同じのようです。
 私のアドエスの、かなり特殊な事例なのかもしれませんね。

 他の多くの方は問題なく動いているようなので、これ以上お手数をおかけするのは大変恐縮です。近日中、アドエス自体を再セットアップする予定でいますので、これでまた問題がでたらご報告致します。
 また現段階で何かお役に立てることがありましたら、仰って下さい。
 ご対応、本当にありがとうございます。

 以上、よろしくお願いいたします。

kazuaki さんのコメント...

SYさん おはようございます。
ご確認ありがとうございます。

起動時だけエラーになると思ったのですが、違っていたようですね。
同様に NDIS関係を使っているWifiInfo等も動かないのでしょうか。

もし再セットアップしてもダメなようであれば また教えてください。